summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rwxr-xr-xdebian/local/runsystem43
2 files changed, 30 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 50ca3f38..ac323f94 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,12 +3,15 @@ hurd (20100829-2) unreleased; urgency=low
[ Samuel Thibault ]
* debian/control: Depend on gcc-4.4 instead of gcc-4.3. Thanks Emilio!
* debian/rules: Fix back debugging symbols into the hurd-dbg package.
+ * debian/local/runsystem: Do not start the Hurd console if the TERM variable
+ is given. Should permit mach-console install for better debugging as well
+ as Xen or sub-hurd support.
[ Jeremie Koenig ]
* debian/patches/libpthread_sigmask.patch: New patch to fix missed signals
when using pthread_sigmask.
- -- Samuel Thibault <sthibault@debian.org> Fri, 03 Sep 2010 02:18:29 +0200
+ -- Samuel Thibault <sthibault@debian.org> Mon, 20 Sep 2010 23:55:18 +0200
hurd (20100829-1) unstable; urgency=low
diff --git a/debian/local/runsystem b/debian/local/runsystem
index 150d4c9c..daff8a0b 100755
--- a/debian/local/runsystem
+++ b/debian/local/runsystem
@@ -8,22 +8,6 @@ export PATH
/hurd/mach-defpager
-# Touch the first tty so that the Hurd console is certain to pick it
-# and not some random other tty.
-sleep 1
-touch /dev/tty1
-
-echo -n "Starting the Hurd console..."
-console -d vga -g -d pc_kbd -c /dev/vcs &
-sleep 1
-
-# Switch over
-exec < /dev/tty1 > /dev/tty1 2>&1
-echo "Console started."
-
-# Set the console device used by /sbin/reopen-console
-echo /dev/tty1 >/var/run/console-device
-
# Get all kernel parameters that can be exported as environment variables
envvars="$(echo $* | tr ' ' '\012' | egrep '^[-_/[:alnum:]]+=.*$')"
@@ -42,8 +26,33 @@ for i in $envvars ; do
noshell=*)
sed -i '/^tty[12]/s/^/#/' /etc/inittab
;;
+ TERM=*)
+ term=yes
+ ;;
esac
done
+if [ "$term" != yes ]
+then
+ # No terminal type set, assume we can start the Hurd console
+
+ # Touch the first tty so that the Hurd console is certain to pick it
+ # and not some random other tty.
+ sleep 1
+ touch /dev/tty1
+
+ echo -n "Starting the Hurd console..."
+ console -d vga -g -d pc_kbd -c /dev/vcs &
+ sleep 1
+
+ # Switch over
+ envvars="$envvars TERM=hurd"
+ exec < /dev/tty1 > /dev/tty1 2>&1
+ echo "Console started."
+
+ # Set the console device used by /sbin/reopen-console
+ echo /dev/tty1 >/var/run/console-device
+fi
+
# Preset the terminal type for /lib/debian-installer/detect-console
-eval exec env - $envvars TERM=hurd TERM_TYPE=virtual $init
+eval exec env - $envvars TERM_TYPE=virtual $init