summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 5 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b247fed6..094f3a56 100755
--- a/debian/rules
+++ b/debian/rules
@@ -45,6 +45,11 @@ install/hurd::
mv debian/tmp/bin/vmstat debian/tmp/usr/bin/vmstat-hurd
mv debian/tmp/bin/w debian/tmp/usr/bin/w-hurd
+ # move away halt and reboot to not conflict with sysvinit
+ # (they will be handled as alternatives)
+ mv debian/tmp/sbin/halt debian/tmp/sbin/halt-hurd
+ mv debian/tmp/sbin/reboot debian/tmp/sbin/reboot-hurd
+
install -m664 debian/hurd-console.default debian/hurd/etc/default/hurd-console
install -m664 $(DEB_SRCDIR)/console/motd.UTF8 debian/hurd/etc/