summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/external.patch4
-rw-r--r--debian/patches/procfs-default.patch4
-rw-r--r--debian/patches/procfs-update.patch14
3 files changed, 17 insertions, 5 deletions
diff --git a/debian/patches/external.patch b/debian/patches/external.patch
index 9cc2f088..0b933712 100644
--- a/debian/patches/external.patch
+++ b/debian/patches/external.patch
@@ -59,7 +59,7 @@ Index: hurd-debian/procfs/Makefile
-TARGET = procfs
-OBJS = procfs.o netfs.o procfs_dir.o \
- process.o proclist.o rootdir.o dircat.o main.o
--LIBS = -lnetfs -lps -lfshelp
+-LIBS = -lnetfs -lps -lfshelp -lpthread
+# Makefile - for procfs
+#
+# Copyright (C) 2008 Free Software Foundation, Inc.
@@ -99,7 +99,7 @@ Index: hurd-debian/procfs/Makefile
-CFLAGS= -g -pg
-CPPFLAGS= -DPROFILE
-LDFLAGS= -static
--LIBS= -lnetfs -lfshelp -liohelp -lps -lports -lthreads -lihash -lshouldbeinlibc
+-LIBS= -lnetfs -lfshelp -liohelp -lps -lports -lpthread -lihash -lshouldbeinlibc
-endif
-
-CPPFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
diff --git a/debian/patches/procfs-default.patch b/debian/patches/procfs-default.patch
index 62cd7b95..023ab9d5 100644
--- a/debian/patches/procfs-default.patch
+++ b/debian/patches/procfs-default.patch
@@ -12,8 +12,8 @@ index ba74e87..3e53307 100644
--- a/procfs/main.c
+++ b/procfs/main.c
@@ -37,6 +37,13 @@ pid_t opt_fake_self;
- pid_t opt_kernel_pid;
- uid_t opt_anon_owner;
+ #define NOEXEC_KEY -2 /* Likewise. */
+ #define NOSUID_KEY -3 /* Likewise. */
+/* Default values */
+#define OPT_CLK_TCK sysconf(_SC_CLK_TCK)
diff --git a/debian/patches/procfs-update.patch b/debian/patches/procfs-update.patch
index fc5cb4a7..67b415ca 100644
--- a/debian/patches/procfs-update.patch
+++ b/debian/patches/procfs-update.patch
@@ -14,7 +14,7 @@ diff --git a/procfs/main.c b/procfs/main.c
index 1b19c01..ba74e87 100644
--- a/procfs/main.c
+++ b/procfs/main.c
-@@ -109,45 +109,82 @@ argp_parser (int key, char *arg, struct argp_state *state)
+@@ -109,51 +109,88 @@ argp_parser (int key, char *arg, struct argp_state *state)
return 0;
}
@@ -44,6 +44,12 @@ index 1b19c01..ba74e87 100644
+ "Be aware that USER will be granted access to the environment and "
+ "other sensitive information about the processes in question. "
+ "(default: use uid 0)" },
++ { "nodev", NODEV_KEY, NULL, 0,
++ "Ignored for compatibility with Linux' procfs." },
++ { "noexec", NOEXEC_KEY, NULL, 0,
++ "Ignored for compatibility with Linux' procfs." },
++ { "nosuid", NOSUID_KEY, NULL, 0,
++ "Ignored for compatibility with Linux' procfs." },
+ {}
+};
+
@@ -74,6 +80,12 @@ index 1b19c01..ba74e87 100644
- "Be aware that USER will be granted access to the environment and "
- "other sensitive information about the processes in question. "
- "(default: use uid 0)" },
+- { "nodev", NODEV_KEY, NULL, 0,
+- "Ignored for compatibility with Linux' procfs." },
+- { "noexec", NOEXEC_KEY, NULL, 0,
+- "Ignored for compatibility with Linux' procfs." },
+- { "nosuid", NOSUID_KEY, NULL, 0,
+- "Ignored for compatibility with Linux' procfs." },
+ .options = common_options,
+ .parser = argp_parser,
+ .doc = "A virtual filesystem emulating the Linux procfs.",