summaryrefslogtreecommitdiff
path: root/debian/patches/libpthread_procfs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/libpthread_procfs.patch')
-rw-r--r--debian/patches/libpthread_procfs.patch70
1 files changed, 64 insertions, 6 deletions
diff --git a/debian/patches/libpthread_procfs.patch b/debian/patches/libpthread_procfs.patch
index 5da9bfba..661c4c0c 100644
--- a/debian/patches/libpthread_procfs.patch
+++ b/debian/patches/libpthread_procfs.patch
@@ -1,8 +1,8 @@
-diff --git a/Makefile b/Makefile
-index 3194473..585d13a 100644
---- a/Makefile
-+++ b/Makefile
-@@ -31,7 +31,8 @@ DIST_FILES = COPYING Makeconf config.make.in configure.in configure \
+Index: hurd-debian/Makefile
+===================================================================
+--- hurd-debian.orig/Makefile 2010-09-27 19:42:53.000000000 +0000
++++ hurd-debian/Makefile 2010-09-27 19:45:57.000000000 +0000
+@@ -31,7 +31,8 @@
# Hurd libraries
lib-subdirs = libshouldbeinlibc libihash libiohelp libports libthreads \
libpager libfshelp libdiskfs libtrivfs libps \
@@ -12,7 +12,7 @@ index 3194473..585d13a 100644
# Hurd programs
prog-subdirs = auth proc exec init term \
-@@ -40,7 +41,7 @@ prog-subdirs = auth proc exec init term \
+@@ -40,7 +41,7 @@
login daemons nfsd boot console \
hostmux usermux ftpfs trans \
console-client utils sutils ufs-fsck ufs-utils \
@@ -21,3 +21,61 @@ index 3194473..585d13a 100644
# Other directories
other-subdirs = hurd doc config release include
+Index: hurd-debian/procfs/Makefile
+===================================================================
+--- hurd-debian.orig/procfs/Makefile 2010-09-27 19:50:41.000000000 +0000
++++ hurd-debian/procfs/Makefile 2010-09-27 19:50:46.000000000 +0000
+@@ -1,26 +1,30 @@
+-TARGET = procfs
+-OBJS = procfs.o netfs.o procfs_dir.o \
+- process.o proclist.o rootdir.o dircat.o main.o
+-LIBS = -lnetfs -lps
++# Makefile - for procfs
++#
++# Copyright (C) 2008 Free Software Foundation, Inc.
++#
++# This program is free software; you can redistribute it and/or
++# modify it under the terms of the GNU General Public License as
++# published by the Free Software Foundation; either version 2, or (at
++# your option) any later version.
++#
++# This program is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY; without even the implied warranty of
++# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
++# General Public License for more details.
++#
++# You should have received a copy of the GNU General Public License
++# along with this program; if not, write to the Free Software
++# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
++
++dir := procfs
++makemode := server
++
++target = procfs
+
+-CC = gcc
+-CFLAGS = -Wall -g
+-CPPFLAGS =
+-LDFLAGS =
++SRCS = procfs.c netfs.c procfs_dir.c process.c proclist.c rootdir.c dircat.c main.c
++LCLHDRS = dircat.h main.h process.h procfs.h procfs_dir.h proclist.h rootdir.h
+
+-ifdef PROFILE
+-CFLAGS= -g -pg
+-CPPFLAGS= -DPROFILE
+-LDFLAGS= -static
+-LIBS= -lnetfs -lfshelp -liohelp -lps -lports -lthreads -lihash -lshouldbeinlibc
+-endif
++OBJS = $(SRCS:.c=.o)
++HURDLIBS = netfs fshelp iohelp ps ports threads ihash shouldbeinlibc
+
+-CPPFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+-
+-all: $(TARGET)
+-
+-$(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS)
+-
+-clean:
+- $(RM) $(TARGET) $(OBJS)
++include ../Makeconf