summaryrefslogtreecommitdiff
path: root/debian/patches/external.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/external.patch')
-rw-r--r--debian/patches/external.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/patches/external.patch b/debian/patches/external.patch
index 9cc2f088..0b933712 100644
--- a/debian/patches/external.patch
+++ b/debian/patches/external.patch
@@ -59,7 +59,7 @@ Index: hurd-debian/procfs/Makefile
-TARGET = procfs
-OBJS = procfs.o netfs.o procfs_dir.o \
- process.o proclist.o rootdir.o dircat.o main.o
--LIBS = -lnetfs -lps -lfshelp
+-LIBS = -lnetfs -lps -lfshelp -lpthread
+# Makefile - for procfs
+#
+# Copyright (C) 2008 Free Software Foundation, Inc.
@@ -99,7 +99,7 @@ Index: hurd-debian/procfs/Makefile
-CFLAGS= -g -pg
-CPPFLAGS= -DPROFILE
-LDFLAGS= -static
--LIBS= -lnetfs -lfshelp -liohelp -lps -lports -lthreads -lihash -lshouldbeinlibc
+-LIBS= -lnetfs -lfshelp -liohelp -lps -lports -lpthread -lihash -lshouldbeinlibc
-endif
-
-CPPFLAGS += -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64