summaryrefslogtreecommitdiff
path: root/debian/patches/external.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/external.patch')
-rw-r--r--debian/patches/external.patch55
1 files changed, 28 insertions, 27 deletions
diff --git a/debian/patches/external.patch b/debian/patches/external.patch
index c0f05fee..c746aac4 100644
--- a/debian/patches/external.patch
+++ b/debian/patches/external.patch
@@ -1,9 +1,11 @@
-Include procfs, random, and DDE in the build
+Include DDE in the build
-diff --git a/Makefile b/Makefile
-index 0b9eff2..12b56f0 100644
---- a/Makefile
-+++ b/Makefile
+TODO: We should turn AC_MSG_WARN into disabling targets
+
+Index: hurd-debian/Makefile
+===================================================================
+--- hurd-debian.orig/Makefile
++++ hurd-debian/Makefile
@@ -28,7 +28,8 @@ include ./Makeconf
# Hurd libraries
lib-subdirs = libshouldbeinlibc libihash libiohelp libports libthreads \
@@ -14,42 +16,41 @@ index 0b9eff2..12b56f0 100644
# Hurd programs
prog-subdirs = auth proc exec term \
-@@ -40,8 +41,9 @@ prog-subdirs = auth proc exec init term \
- benchmarks fstests \
- random \
+@@ -37,6 +38,7 @@ prog-subdirs = auth proc exec init term
procfs \
startup \
init \
-+ devnode \
++ devnode
ifeq ($(HAVE_SUN_RPC),yes)
prog-subdirs += nfs nfsd
-diff --git a/configure.ac b/configure.ac
-index 05b959b..68ec159 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -227,6 +227,12 @@ AC_SUBST(boot_store_types)dnl
+Index: hurd-debian/Makeconf
+===================================================================
+--- hurd-debian.orig/Makeconf
++++ hurd-debian/Makeconf
+@@ -576,7 +576,7 @@ vpath %.defs $(top_srcdir)/hurd
+ # These we want to find in the libc include directory...
+ mach_defs_names = bootstrap exc mach mach4 \
+ mach_host mach_port mach_timer_reply memory_object \
+- memory_object_default notify \
++ memory_object_default notify experimental \
+ gnumach \
+ task_notify \
+
+Index: hurd-debian/configure.ac
+===================================================================
+--- hurd-debian.orig/configure.ac
++++ hurd-debian/configure.ac
+@@ -241,6 +241,12 @@ AC_SUBST(boot_store_types)dnl
AC_MSG_CHECKING(boot store types)
AC_MSG_RESULT($boot_store_types)
+AC_CHECK_LIB(pciaccess, pci_system_init, LIBPCIACCESS=-lpciaccess, LIBPCIACCESS=no)
+AC_SUBST(LIBPCIACCESS)
+if test "$LIBPCIACCESS" = "no"; then
-+ AC_MSG_ERROR([libpciaccess must be install in order to use libddekit])
++ AC_MSG_WARN([libpciaccess must be install in order to use libddekit])
+fi
+
# Check for ncursesw, which is needed for the console-curses client.
hurd_LIB_NCURSESW
-diff --git a/Makeconf b/Makeconf
-index 5439913..1d70e53 100644
---- a/Makeconf
-+++ b/Makeconf
-@@ -582,6 +582,7 @@ mach_defs_names = bootstrap exc mach mach4 \
- mach_debug_defs_names = mach_debug
- device_defs_names = dev_forward device device_reply device_request
-
-+mach_defs_names += experimental
- mach_defs = $(addsuffix .defs,$(mach_defs_names))
- mach_debug_defs = $(addsuffix .defs,$(mach_debug_defs_names))
- device_defs = $(addsuffix .defs,$(device_defs_names))