summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarcus Brinkmann <marcus@gnu.org>2001-07-18 19:51:23 +0000
committerMarcus Brinkmann <marcus@gnu.org>2001-07-18 19:51:23 +0000
commitfaa783b87a2dfaf123447773b40d6ce20b951378 (patch)
treedd5cc671a99e0b541ca562441efc152da470b4e3 /debian
parenta0faecab9371d537a3d8d18f451421bc31ef6a07 (diff)
2001-07-18 Marcus Brinkmann <marcus@gnu.org>
* copyright: Refer to new directory. * rules: Move documentation to share directory. Add -isp to dpkg-gencontrol invocation. Remove crufty hurd.info. * control: Bump up standards version.
Diffstat (limited to 'debian')
-rw-r--r--debian/ChangeLog8
-rw-r--r--debian/control2
-rw-r--r--debian/copyright2
-rwxr-xr-xdebian/rules12
4 files changed, 17 insertions, 7 deletions
diff --git a/debian/ChangeLog b/debian/ChangeLog
index 8d6d4f25..065a778a 100644
--- a/debian/ChangeLog
+++ b/debian/ChangeLog
@@ -1,5 +1,13 @@
2001-07-18 Marcus Brinkmann <marcus@gnu.org>
+ * copyright: Refer to new directory.
+ * rules: Move documentation to share directory.
+ Add -isp to dpkg-gencontrol invocation.
+ Remove crufty hurd.info.
+ * control: Bump up standards version.
+
+2001-07-18 Marcus Brinkmann <marcus@gnu.org>
+
* rc: Do not excempt random-seed when cleaning up /var/run. State
data should be in /var/lib (FHS) or /var/state.
* changelog: Update to current version.
diff --git a/debian/control b/debian/control
index 2f1bff32..0b6e9e50 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: hurd
Section: base
Priority: required
Maintainer: GNU Hurd Maintainers <bug-hurd@gnu.org>
-Standards-Version: 2.5.0.0
+Standards-Version: 3.5.5.0
Build-Depends: mig, texinfo, tetex-bin
Package: hurd
diff --git a/debian/copyright b/debian/copyright
index 784f5768..4ad4e650 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -26,4 +26,4 @@ Public License).
Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
On Debian GNU/Linux systems, the complete text of the GNU General
-Public License can be found in `/usr/doc/copyright/GPL'.
+Public License can be found in `/usr/share/common-licenses/GPL'.
diff --git a/debian/rules b/debian/rules
index a1efd14e..765be358 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,7 +28,7 @@ PREFIX = /usr
BINDIR = $(PREFIX)/bin
MANDIR = $(PREFIX)/man
INFODIR = $(PREFIX)/info
-DOCDIR = $(PREFIX)/doc/$(package)
+DOCDIR = $(PREFIX)/share/doc/$(package)
# Package specific stuff. The idea is to try to make the rules
# generic (gradually).
@@ -125,8 +125,8 @@ binary-arch: build
# now distribute the files
# first the source package
- $(make_directory) debian/$(package)-dev/{DEBIAN,usr/{doc,bin,lib}}
- ln -s $(package) debian/$(package)-dev/usr/doc/$(package)-dev
+ $(make_directory) debian/$(package)-dev/{DEBIAN,usr/{share/doc,bin,lib}}
+ ln -s $(package) debian/$(package)-dev$(DOCDIR)-dev
mv debian/tmp/include debian/$(package)-dev/usr/.
mv debian/tmp/lib/*.a debian/$(package)-dev/usr/lib/.
# Create development library links.
@@ -136,7 +136,7 @@ binary-arch: build
done
rm -f debian/tmp/lib/*.so
- dpkg-gencontrol -p$(package)-dev -Pdebian/$(package)-dev
+ dpkg-gencontrol -isp -p$(package)-dev -Pdebian/$(package)-dev
chown -R root.root debian/$(package)-dev
dpkg --build debian/$(package)-dev ..
@@ -165,6 +165,8 @@ binary-arch: build
# XXX-doc
$(install_file) build/doc/hurd.info* debian/tmp$(INFODIR)
-gzip -9frq debian/tmp$(INFODIR)
+# XXX Remove the vague attempt of the makefiles to install the docs.
+ rm -fR debian/tmp/info
$(install_file) debian/servers.boot debian/tmp/boot/servers.boot
$(make_directory) debian/tmp/servers
@@ -185,7 +187,7 @@ binary-arch: build
debian/tmp/libexec/* debian/tmp/hurd/* \
debian/tmp/sbin/* ; do head -n1 $$f \
| sed -n -e '/^#!/!a\'$$'\n'$$f ; done`
- dpkg-gencontrol -p$(package) -Pdebian/tmp
+ dpkg-gencontrol -isp -p$(package) -Pdebian/tmp
chown -R root.root debian/tmp
dpkg --build debian/tmp ..