summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarcus Brinkmann <marcus@gnu.org>2001-10-12 23:25:24 +0000
committerMarcus Brinkmann <marcus@gnu.org>2001-10-12 23:25:24 +0000
commitdb1e1c57899cddcd1d51964949f3cc92393cfcf7 (patch)
treefc3871550dc3c33720cf7d1e13211fa2d54528fc /debian
parentc018d558e1b3ed9bb955846013bdee0913f8eb5b (diff)
2001-10-13 Marcus Brinkmann <marcus@gnu.org>
* debian/rules: New dpkg-shlibdeps is more strict and complains about statically linked files, so a new filter is necessary. * debian/control: Add `file' to build dependencies. By Kevin Kreamer <kkreamer@etherhogz.org>. * debian/changelog: Update for new release.
Diffstat (limited to 'debian')
-rw-r--r--debian/ChangeLog9
-rw-r--r--debian/changelog11
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules14
4 files changed, 30 insertions, 6 deletions
diff --git a/debian/ChangeLog b/debian/ChangeLog
index e03c462c..f7454a32 100644
--- a/debian/ChangeLog
+++ b/debian/ChangeLog
@@ -1,3 +1,12 @@
+2001-10-13 Marcus Brinkmann <marcus@gnu.org>
+
+ * debian/rules: New dpkg-shlibdeps is more strict and complains
+ about statically linked files, so a new filter is necessary.
+ * debian/control: Add `file' to build dependencies.
+ By Kevin Kreamer <kkreamer@etherhogz.org>.
+
+ * debian/changelog: Update for new release.
+
2001-10-01 Marcus Brinkmann <marcus@gnu.org>
* changelog: Update to current version.
diff --git a/debian/changelog b/debian/changelog
index 1fd4da25..4fcefd7a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+hurd (20010817-3) unstable; urgency=low
+
+ * New snapshot from CVS.
+ * Additional patches:
+ kbd, mouse as usual.
+ Change terminal type to mach-color.
+ * debian/rules: Change way how to find executables by Kevin Kreamer.
+ * debian/control: Add `file' to build dependencies by Kevin Kreamer.
+
+ -- Marcus Brinkmann <brinkmd@debian.org> Sat, 13 Oct 2001 01:05:30 +0200
+
hurd (20010817-2) unstable; urgency=low
* Include a copy of update-rc.d, moved from dpkg to init providing
diff --git a/debian/control b/debian/control
index 0b6e9e50..d704fa94 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: base
Priority: required
Maintainer: GNU Hurd Maintainers <bug-hurd@gnu.org>
Standards-Version: 3.5.5.0
-Build-Depends: mig, texinfo, tetex-bin
+Build-Depends: file, mig, texinfo, tetex-bin
Package: hurd
Priority: required
diff --git a/debian/rules b/debian/rules
index 06fa19e5..c5dea47f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -183,11 +183,15 @@ binary-arch: build
$(install_script) debian/postinst debian/tmp/DEBIAN/postinst
$(install_script) debian/prerm debian/tmp/DEBIAN/prerm
- # Filter out scripts.
- dpkg-shlibdeps -p$(package) `for f in debian/tmp/bin/* \
- debian/tmp/libexec/* debian/tmp/hurd/* \
- debian/tmp/sbin/* ; do head -n1 $$f \
- | sed -n -e '/^#!/!a\'$$'\n'$$f ; done`
+ # Get list of dynamically linked executables
+ dpkg-shlibdeps -p$(package) \
+ `file debian/tmp/bin/* \
+ debian/tmp/hurd/* \
+ debian/tmp/lib/* \
+ debian/tmp/libexec/* \
+ debian/tmp/sbin/* \
+ | egrep '(executable.*dynamic)|(shared object)' \
+ | cut -f 1 -d ':'`
dpkg-gencontrol -isp -p$(package) -Pdebian/tmp
chown -R root.root debian/tmp
dpkg --build debian/tmp ..