summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1999-04-29 16:20:08 +0000
committerRoland McGrath <roland@gnu.org>1999-04-29 16:20:08 +0000
commit92857867160d3de672d1a36276e0060e8b8a5b05 (patch)
tree5e371deda5001f41171f22cd6b588e72ddd360bd /debian
parent487be3fdb025418ff78ffe0640aac35b34d42cc7 (diff)
1999-04-28 Roland McGrath <roland@baalperazim.frob.com>
* rules (binary-arch): Add etc, etc/login subdirs to chmod cmd. Use $(addprefix) fn to avoid repetition.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules5
1 files changed, 4 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index be9677ce..5480046e 100755
--- a/debian/rules
+++ b/debian/rules
@@ -97,7 +97,10 @@ binary-arch: build
-strip --strip-all debian/tmp/hurd/*
-strip --strip-all debian/tmp/libexec/*
chmod 0644 debian/tmp/lib/lib*.a
- chmod 0755 debian/tmp/include debian/tmp/include/hurd debian/tmp/lib debian/tmp/hurd debian/tmp/bin debian/tmp/sbin debian/tmp/dev debian/tmp/libexec debian/tmp/etc debian/tmp/etc/login
+ chmod 0755 $(addprefix debian/tmp/, \
+ include include/hurd \
+ lib hurd bin sbin \
+ dev libexec etc etc/login)
# now distribute the files
# first the source package