summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1999-10-08 22:57:32 +0000
committerRoland McGrath <roland@gnu.org>1999-10-08 22:57:32 +0000
commit1ec352274778dc9ffbe2e0d53e67ee54ac2b3f23 (patch)
tree1161ecf7ac959d8ee2689b0b41bc0d485cb3766f /debian
parent0643845395790683a7afe122338e21c9501b72a4 (diff)
1999-10-09 Marcus Brinkmann <marcus@gnu.org>
* rules (BUILDARCH): Renamed to DEB_BUILD_GNU_TYPE. (HOSTARCH): Renamed to DEB_HOST_GNU_TYPE. (INFODIR): New variable. (STAMPS_TO_CLEAN): Add stamp-config. (configure): Depend on configure.in. (config, stamp-config): New targets. (stamp-build): Build info documentation. (clean): Do not clean up build directory, it will be removed. Clean documentation directory. (binary-arch): Remove etc/motd. Expand bash {,} syntax. Gzip serverboot. Install additional documentation formats. Rename libexec/runsystem to libexec/runsystem.gnu. Install postinst, prerm (.PHONY): Add config. * postinst, prerm: New Files. * shlibs,shlibs.local: Remove libmom. * changelog: Update to reflect Debian uploads.
Diffstat (limited to 'debian')
-rw-r--r--debian/postinst89
-rw-r--r--debian/prerm71
2 files changed, 160 insertions, 0 deletions
diff --git a/debian/postinst b/debian/postinst
new file mode 100644
index 00000000..89c26bec
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,89 @@
+#! /bin/sh
+# postinst.skeleton
+# Skeleton maintainer script showing all the possible cases.
+# Written by Charles Briscoe-Smith, March-June 1998. Public Domain.
+
+# Abort if any command returns an error value
+set -e
+
+# This script is called as the last step of the installation of the
+# package. All the package's files are in place, dpkg has already done
+# its automatic conffile handling, and all the packages we depend of
+# are already fully installed and configured.
+
+# The following idempotent stuff doesn't generally need protecting
+# against being run in the abort-* cases.
+
+# Install info files into the dir file.
+
+install-info --quiet --section "Hurd" "The Hurd" /usr/info/hurd.info.gz
+
+# Manage alternatives.
+
+update-alternatives --quiet \
+ --install /libexec/runsystem runsystem /libexec/runsystem.gnu 20
+
+# Take care that a "login" user exists. Useful for our login shell.
+
+if ! grep --quiet '^login:' /etc/passwd ; then
+ adduser --quiet --system --home /etc/login --gecos "Not logged in" --no-create-home login
+ chsh -s /bin/bash login
+fi
+
+case "$1" in
+ configure)
+ # Configure this package. If the package must prompt the user for
+ # information, do it here.
+
+ # There are three sub-cases:
+ if test "${2+set}" != set; then
+ # We're being installed by an ancient dpkg which doesn't remember
+ # which version was most recently configured, or even whether
+ # there is a most recently configured version.
+ :
+
+ elif test -z "$2" -o "$2" = "<unknown>"; then
+ # The package has not ever been configured on this system, or was
+ # purged since it was last configured.
+ :
+
+ else
+ # Version $2 is the most recently configured version of this
+ # package.
+ :
+
+ fi ;;
+ abort-upgrade)
+ # Back out of an attempt to upgrade this package FROM THIS VERSION
+ # to version $2. Undo the effects of "prerm upgrade $2".
+ :
+
+ ;;
+ abort-remove)
+ if test "$2" != in-favour; then
+ echo "$0: undocumented call to \`postinst $*'" 1>&2
+ exit 0
+ fi
+ # Back out of an attempt to remove this package, which was due to
+ # a conflict with package $3 (version $4). Undo the effects of
+ # "prerm remove in-favour $3 $4".
+ :
+
+ ;;
+ abort-deconfigure)
+ if test "$2" != in-favour -o "$5" != removing; then
+ echo "$0: undocumented call to \`postinst $*'" 1>&2
+ exit 0
+ fi
+ # Back out of an attempt to deconfigure this package, which was
+ # due to package $6 (version $7) which we depend on being removed
+ # to make way for package $3 (version $4). Undo the effects of
+ # "prerm deconfigure in-favour $3 $4 removing $6 $7".
+ :
+
+ ;;
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+
+exit 0
diff --git a/debian/prerm b/debian/prerm
new file mode 100644
index 00000000..e6adae87
--- /dev/null
+++ b/debian/prerm
@@ -0,0 +1,71 @@
+#!/bin/sh
+
+# Abort if any command returns an error value
+set -e
+
+# This script is called as the first step in removing the package from
+# the system. This includes cases where the user explicitly asked for
+# the package to be removed, upgrade, automatic removal due to conflicts,
+# and deconfiguration due to temporary removal of a depended-on package.
+
+# Info files should be uninstalled from the dir file in any case.
+install-info --quiet --remove hurd
+
+# Because we run this in almost all cases, we do it here instead below.
+
+if [ "$1" != "upgrade" ]; then
+ update-alternatives --remove runsystem /libexec/runsystem.gnu
+fi
+
+case "$1" in
+ remove)
+ # This package about to be removed.
+ :
+
+ # There are two sub-cases:
+ if test "${2+set}" = set; then
+ if test "$2" != in-favour; then
+ echo "$0: undocumented call to \`prerm $*'" 1>&2
+ exit 0
+ fi
+ # We are being removed because of a conflict with package $3
+ # (version $4), which is now being installed.
+ :
+
+ else
+ # The package is being removed in its own right.
+ :
+
+ fi
+
+
+ ;;
+
+ deconfigure)
+ if test "$2" != in-favour -o "$5" != removing; then
+ echo "$0: undocumented call to \`prerm $*'" 1>&2
+ exit 0
+ fi
+ # Package $6 (version $7) which we depend on is being removed due
+ # to a conflict with package $3 (version $4), and this package is
+ # being deconfigured until $6 can be reinstalled.
+ :
+
+ ;;
+ upgrade)
+ # Prepare to upgrade FROM THIS VERSION of this package to version $2.
+ :
+
+ ;;
+ failed-upgrade)
+ # Prepare to upgrade from version $2 of this package TO THIS VERSION.
+ # This is only used if the old version's prerm couldn't handle it,
+ # and returned non-zero. (Fix old prerm bugs here.)
+ :
+
+ ;;
+ *) echo "$0: didn't understand being called with \`$1'" 1>&2
+ exit 0;;
+esac
+
+exit 0