summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMarcus Brinkmann <marcus@gnu.org>2001-10-12 23:25:24 +0000
committerMarcus Brinkmann <marcus@gnu.org>2001-10-12 23:25:24 +0000
commitdb1e1c57899cddcd1d51964949f3cc92393cfcf7 (patch)
treefc3871550dc3c33720cf7d1e13211fa2d54528fc /debian/rules
parentc018d558e1b3ed9bb955846013bdee0913f8eb5b (diff)
2001-10-13 Marcus Brinkmann <marcus@gnu.org>
* debian/rules: New dpkg-shlibdeps is more strict and complains about statically linked files, so a new filter is necessary. * debian/control: Add `file' to build dependencies. By Kevin Kreamer <kkreamer@etherhogz.org>. * debian/changelog: Update for new release.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules14
1 files changed, 9 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index 06fa19e5..c5dea47f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -183,11 +183,15 @@ binary-arch: build
$(install_script) debian/postinst debian/tmp/DEBIAN/postinst
$(install_script) debian/prerm debian/tmp/DEBIAN/prerm
- # Filter out scripts.
- dpkg-shlibdeps -p$(package) `for f in debian/tmp/bin/* \
- debian/tmp/libexec/* debian/tmp/hurd/* \
- debian/tmp/sbin/* ; do head -n1 $$f \
- | sed -n -e '/^#!/!a\'$$'\n'$$f ; done`
+ # Get list of dynamically linked executables
+ dpkg-shlibdeps -p$(package) \
+ `file debian/tmp/bin/* \
+ debian/tmp/hurd/* \
+ debian/tmp/lib/* \
+ debian/tmp/libexec/* \
+ debian/tmp/sbin/* \
+ | egrep '(executable.*dynamic)|(shared object)' \
+ | cut -f 1 -d ':'`
dpkg-gencontrol -isp -p$(package) -Pdebian/tmp
chown -R root.root debian/tmp
dpkg --build debian/tmp ..