summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorThomas Schwinge <tschwinge@gnu.org>2007-11-07 13:07:52 +0000
committerThomas Schwinge <tschwinge@gnu.org>2007-11-07 13:07:52 +0000
commitf30c5fcd15ee56781db9e88c1c40f2fe6c856a4e (patch)
treec64a29805898ba6af022d4f0d0503163a63cf904 /configure.in
parentc1b43b0f2d28f6c103d1170cf064a86d6e4fd26c (diff)
2007-11-07 Thomas Schwinge <tschwinge@gnu.org>
* config.make.in (gnu89-inline-CFLAGS): New variable. * Makeconf (CFLAGS): Evaluate that one instead of hard-coding. Suggested by Olaf Buddenhagen, <http://lists.gnu.org/archive/html/bug-hurd/2007-11/msg00006.html> * configure.in (libc_cv_gnu89_inline): Fill depending on a compile-time test, as per glibc HEAD, 2007-11-07.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 28 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 74fc9d13..a7bc4807 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.36 2005/04/07 20:48:40 ams Exp $])
+AC_REVISION([$Id: configure.in,v 1.37 2007/11/07 13:07:52 tschwinge Exp $])
AC_PREREQ(2.54) dnl Minimum Autoconf version required.
AC_INIT
AC_CONFIG_SRCDIR([hurd/hurd_types.h]) dnl File to look for in srcdir.
@@ -156,6 +156,33 @@ AC_SUBST(VERSIONING)
# Check if libc contains getgrouplist and/or uselocale.
AC_CHECK_FUNCS(getgrouplist uselocale)
+
+# From glibc HEAD, 2007-11-07.
+AC_CACHE_CHECK(for -fgnu89-inline, libc_cv_gnu89_inline, [dnl
+cat > conftest.c <<EOF
+int foo;
+#ifdef __GNUC_GNU_INLINE__
+main () { return 0;}
+#else
+#error
+#endif
+EOF
+if AC_TRY_COMMAND([${CC-cc} $CFLAGS $CPPFLAGS -S -std=gnu99 -fgnu89-inline
+ -o conftest.s conftest.c 1>&AS_MESSAGE_LOG_FD])
+then
+ libc_cv_gnu89_inline=yes
+else
+ libc_cv_gnu89_inline=no
+fi
+rm -f conftest*])
+if test $libc_cv_gnu89_inline = yes; then
+ libc_cv_gnu89_inline=-fgnu89-inline
+else
+ libc_cv_gnu89_inline=
+fi
+AC_SUBST(libc_cv_gnu89_inline)
+
+
AC_ARG_WITH(parted, dnl
[ --without-parted don't try to use GNU Parted libraries],
, with_parted=yes)