summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1998-08-12 20:56:17 +0000
committerRoland McGrath <roland@gnu.org>1998-08-12 20:56:17 +0000
commitc717a173a769e1fa366615a44ccf9cddec1a0c7d (patch)
tree72641a361d95cc27ce729bac22894e529e5b7853 /configure.in
parent9283bb15f7d70c3825943367249a4e2871d80e0f (diff)
1998-08-12 Roland McGrath <roland@baalperazim.frob.com>
* aclocal.m4 (AC_PROG_CC_LOCAL): Renamed to hurd_PROG_CC. (AC_PROG_CC_WORKS_LOCAL): Renamed to hurd_PROG_CC_WORKS. * configure.in: Use hurd_PROG_CC instead of AC_PROG_CC_LOCAL. (AC_PREREQ): Require 2.12. (AC_CANONICAL_HOST): Give helpful error messages for likely cases of bogus host specs. (crypt check): Don't do AC_CHECK_FUNCS to get HAVE_CRYPT, just check for -lcrypt to set $LIBCRYPT.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 15 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 1dad5b58..64960998 100644
--- a/configure.in
+++ b/configure.in
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.13 1998/07/20 04:55:13 roland Exp $])
-AC_PREREQ(2.4) dnl Minimum Autoconf version required.
+AC_REVISION([$Id: configure.in,v 1.14 1998/08/12 20:56:17 roland Exp $])
+AC_PREREQ(2.12) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
AC_PREFIX_DEFAULT() dnl Default to empty prefix, not /usr/local.
@@ -8,14 +8,20 @@ AC_PREFIX_DEFAULT() dnl Default to empty prefix, not /usr/local.
AC_CANONICAL_HOST
case "$host_os" in
gnu*) ;;
-*) AC_MSG_ERROR([sorry, this is the gnu os, not $host_os]) ;;
+none) AC_MSG_ERROR([
+*** You must specify a host of $host_cpu-gnu or $host_cpu-$host_vendor-gnu
+*** to configure; you will need to use the same host specification
+*** to configure other packages for the GNU/Hurd system.]) ;;
+*) AC_MSG_ERROR([this is the gnu os, host cannot be $host_os
+*** Host configuration must be \`MACHINE-gnu' or \`MACHINE-VENDOR-gnu'.
+*** To cross-compile, you must specify both --host and --build;
+*** for example \`--build=$host --host=$host_cpu-gnu'.
+*** Run $0 --help for more information.]) ;;
esac
case "$host_cpu" in
-i[[3456]]86)
- asm_syntax=i386
- ;;
-*) AC_MSG_ERROR([unspported CPU type]) ;;
+i?86) asm_syntax=i386 ;;
+*) AC_MSG_ERROR([unsupported CPU type]) ;;
esac
AC_SUBST(asm_syntax)
@@ -29,7 +35,7 @@ AC_PROG_INSTALL
AC_CHECK_TOOL(CC, gcc)
# That check handles cross-compilation well, but AC_PROG_CC tests for GCC
# and sets default CFLAGS nicely for us, so do that too.
-AC_PROG_CC_LOCAL
+hurd_PROG_CC
# Require GCC.
if test x$GCC != xyes; then
AC_MSG_ERROR([this code uses GNU C extensions, you must compile with GCC])
@@ -44,14 +50,9 @@ AC_CHECK_TOOL(MIG, mig)
dnl Let these propagate from the environment.
AC_SUBST(CFLAGS) AC_SUBST(CPPFLAGS) AC_SUBST(LDFLAGS)
-# See if there's a separate libcrypt (many systems put crypt there)
+# See if there's a separate libcrypt (many systems put crypt there).
AC_CHECK_LIB(crypt, crypt, LIBCRYPT=-lcrypt)
AC_SUBST(LIBCRYPT)
-# Look for the crypt function itself (in libcrypt if possible)
-_SAVE_LIBS="$LIBS"
-LIBS="$LIBCRYPT $LIBS"
-AC_CHECK_FUNCS(crypt)
-LIBS="$_SAVE_LIBS"
if test -f ./$ac_unique_file; then
# Configuring in source directory; don't create any Makefiles.