summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1996-03-25 08:09:03 +0000
committerRoland McGrath <roland@gnu.org>1996-03-25 08:09:03 +0000
commitbb74d931d6ded15b7bb587d1cc2e168cb91193f3 (patch)
tree3b0b6ea5679b067d577c6d86b2c9b5dd8fa295d1 /configure.in
parent74df62968161b52bec92c1df8b0f138764cbe8cc (diff)
After CC tool check, invoke AC_PROG_CC to set default CFLAGS and test for GCC.
Barf if not GCC.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7603efca..dc5039d4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_REVISION([$Id: configure.in,v 1.2 1995/09/21 23:07:35 roland Exp $])
+AC_REVISION([$Id: configure.in,v 1.3 1996/03/25 08:09:03 roland Exp $])
AC_PREREQ(2.4) dnl Minimum Autoconf version required.
AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
@@ -12,7 +12,16 @@ gnu*) ;;
esac
AC_PROG_INSTALL
+
AC_CHECK_TOOL(CC, gcc)
+# That check handles cross-compilation well, but AC_PROG_CC tests for GCC
+# and sets default CFLAGS nicely for us, so do that too.
+AC_PROG_CC
+# Require GCC.
+if test x$GCC != xyes; then
+ AC_MSG_ERROR([this code uses GNU C extensions, you must compile with GCC])
+fi
+
AC_CHECK_TOOL(LD, ld)
AC_CHECK_TOOL(OBJCOPY, objcopy)
AC_CHECK_TOOL(AR, ar)