summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRoland McGrath <roland@gnu.org>1995-09-16 18:19:43 +0000
committerRoland McGrath <roland@gnu.org>1995-09-16 18:19:43 +0000
commit3180ede9c84b0511a92d897efeae6f597999de54 (patch)
tree879ea308eb272f3d1237d6b153cc75319fa0f4ea /configure.in
parent144cbaa73df79e02dcc933c9bc49249fc56fb568 (diff)
Initial revision
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in32
1 files changed, 32 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 00000000..1d63b3ac
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,32 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_REVISION([$Id: configure.in,v 1.1 1995/09/16 18:19:43 roland Exp $])
+AC_PREREQ(2.4) dnl Minimum Autoconf version required.
+AC_INIT(hurd/hurd_types.h) dnl A distinctive file to look for in srcdir.
+
+AC_PREFIX_DEFAULT() dnl Default to empty prefix, not /usr/local.
+
+AC_CANONICAL_HOST
+case "$host_os" in
+gnu*) ;;
+*) AC_MSG_ERROR([sorry, this is the gnu os, not $host_os]) ;;
+esac
+
+AC_PROG_INSTALL
+AC_CHECK_TOOL(CC, gcc)
+AC_CHECK_TOOL(LD, ld)
+AC_CHECK_TOOL(OBJCOPY, objcopy)
+AC_CHECK_TOOL(AR, ar)
+AC_CHECK_TOOL(RANLIB, ranlib)
+AC_CHECK_TOOL(MIG, mig)
+
+dnl Let these propagate from the environment.
+AC_SUBST(CFLAGS) AC_SUBST(CPPFLAGS) AC_SUBST(LDFLAGS)
+
+AC_OUTPUT(config.make)
+
+dnl Local Variables:
+dnl comment-start: "dnl "
+dnl comment-end: ""
+dnl comment-start-skip: "\\bdnl\\b\\s *"
+dnl compile-command: "autoconf"
+dnl End: