summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorDiego Nieto Cid <dnietoc@gmail.com>2011-04-03 00:02:46 -0300
committerDiego Nieto Cid <dnietoc@gmail.com>2011-04-08 14:47:35 -0300
commit8582683290c390d8e5f551f35886eb2453f7f8e7 (patch)
tree02a0788bb5df15ddf08010e61b170e70d3848146 /configure.in
parentd6f6e1bf7e3eaacb2ce134e40737319e9cf306a8 (diff)
Depend on X11 for string to keysym mappings.
* config.make.in (HAVE_X11,X11_CFLAGS,X11_LIBS,XKB_BASE): New variables. * configure.in: Check for x11 module. * console-client/Makefile (PC_KBD_SO_SRCS): Move XKB sources... * console-client/Makefile (XKB_SRCS): ... here. New variable. * console-client/Makefile (SRCS): Add $(XKB_SRCS). * console-client/Makefile (LCLHDRS): Add xkb/xkb.h. * console-client/Makefile (XKB_DATA_DIR): Removed variable. * console-client/Makefile (pc_kbd.so.$(hurd-version)): Use patsubst. Depend on XKB objects when HAVE_X11 = yes. * console-client/Makefile (install): Depend on XKB datafiles when HAVE_X11 = yes. * console-client/Makefile (pc-kbd-CFLAGS): Set variable when HAVE_X11 = yes * console-client/Makefile ($(XKB_DATA_DIR),$(XKB_DATA_DIR)/%): Replaced by... * console-client/Makefile[HAVE_X11=yes]($(XKB_BASE),$(XKB_BASE)/%): ... this targets. * console-client/Makefile[HAVE_X11=yes](pc_kbd-LDLIBS): New variable. * console-client/xkb/keysymdef.h: Removed file. * console-client/xkb/ks_tables.h: Likewise. * console-client/xkb/symname.c: Likewise. * console-client/xkb/xkb.c: Include <X11/keysymdef.h>. * console-client/xkb/compose.c: Likewise. * console-client/xkb/xkb.h: Remove XStringToKeysym prototype. Include <X11/Xlib.h>.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1cf4daab..967e86c9 100644
--- a/configure.in
+++ b/configure.in
@@ -230,6 +230,21 @@ AC_MSG_RESULT($boot_store_types)
# Check for ncursesw, which is needed for the console-curses client.
hurd_LIB_NCURSESW
+# Check for those Xorg modules needed for keyboard mappings.
+PKG_CHECK_MODULES([X11], [x11 xproto],
+ [ have_x11=yes
+ pkg_failed=no
+ AC_MSG_CHECKING([for xkb base])
+ _PKG_CONFIG([XKB_BASE], [variable=xkb_base], [xkeyboard-config])
+ AS_IF([test $pkg_failed = no],
+ [XKB_BASE="$pkg_cv_XKB_BASE"
+ AC_MSG_RESULT([$XKB_BASE])],
+ [XKB_BASE="$datadir/X11/xkb"
+ AC_MSG_RESULT([(default) $XKB_BASE])])
+ ], [have_x11=no])
+AC_SUBST([have_x11])
+AC_SUBST([XKB_BASE])
+
if test -f ./$ac_unique_file; then
# Configuring in source directory; don't create any Makefiles.
makefiles=