summaryrefslogtreecommitdiff
path: root/i386/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'i386/configure.in')
-rw-r--r--i386/configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/i386/configure.in b/i386/configure.in
index afc931b..93d7476 100644
--- a/i386/configure.in
+++ b/i386/configure.in
@@ -22,9 +22,21 @@ AC_PREREQ(2.57)
#
# Options
#
+AC_ARG_ENABLE([default-device-drivers],
+AS_HELP_STRING([--disable-default-device-drivers], [have all device drivers
+disabled that can be disabled and would otherwise have been enabled by default;
+then use the `--enable-*' options to enable only those you actually want to
+have enabled]))
+[if test x"$enable_default_device_drivers" != xno
+then enable_default_device_drivers=yes
+fi]
+
AC_ARG_ENABLE([lpr],
-AS_HELP_STRING([--enable-lpr], [enable use of lpr device]),
-[test "x$enableval" = xno || AC_DEFINE([MACH_LPR], [], [enable mach lpr])])
+ AS_HELP_STRING([--disable-lpr], [disable use of lpr device]))
+[enable_lpr=${enable_lpr-$enable_default_device_drivers}
+if test x"$enable_lpr" = xyes
+then] AC_DEFINE([MACH_LPR], [], [enable mach lpr])
+[fi]
AC_CONFIG_SUBDIRS([linux])