summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6885f6b..50aabe4 100644
--- a/configure.in
+++ b/configure.in
@@ -21,10 +21,15 @@ AC_INIT(kern/ipc_kobject.c)
AC_CANONICAL_HOST
case "$host_cpu" in
-i[[345]]86) systype=i386 ;;
+i[[3456]]86) systype=i386 ;;
*) AC_MSG_ERROR([unsupported CPU type]) ;;
esac
+case "$host_os" in
+gnu*) ;;
+*) AC_MSG_ERROR([sorry, this is the gnu os, not $host_os]) ;;
+esac
+
AC_SUBST(systype)
AC_SUBST(cross_compiling)