summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 19 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9aa6ba6..9a8c4ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,13 +101,25 @@ AC_CHECK_PROG([PATCH], [patch], [patch], [patch-not-found])
m4_include([tests/configfrag.ac])
# Default set of device drivers.
-AC_ARG_ENABLE([default-device-drivers],
- AS_HELP_STRING([--disable-default-device-drivers], [have the options marked
- with ``enabled by default'' disabled by default; then use the `--enable-*'
- options to enable only those you actually want to have enabled]))
-[if [ x"$enable_default_device_drivers" != xno ]
-then enable_default_device_drivers=yes
-fi]
+AC_ARG_ENABLE([device-drivers],
+ AS_HELP_STRING([--enable-device-drivers=WHICH], [specify WHICH (on `ix86-at'
+ one of `default', `qemu', `none') to preset a certain subset of all
+ available device drivers, as indicated by the below-metioned ``enabled
+ ...'' comments; you can then still use further `--enable-*' or
+ `--disable-*' options to refine the selection of drivers to include in
+ order to choose only those you actually want to have enabled]))
+[case $enable_device_drivers in
+ '')
+ enable_device_drivers=default;;
+ no)
+ enable_device_drivers=none;;
+ default | none | qemu)
+ :;;
+ *)]
+ AC_MSG_ERROR([invalid choice of]
+ [`--enable-device-drivers=$enable_device_drivers'.])
+ [;;
+esac]
# Platform-specific configuration.