summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 6bca83a..a2cf47f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -116,12 +116,12 @@ include doc/Makefrag.am
# Kernel Image
#
+# We need the following junk because of the include-files-from-libc.a magic.
# TODO. Is the following kosher from a Automake point of view? (I.e. a
# program `gnumach.o' that is then later used again as an object file.)
gnumach_o_SOURCES =
-# TODO. ``--start-group''. Want to keep it that way?
# TODO. ``-u _start''. System dependent?
-gnumach_o_LINK = $(LD) -u _start -r -o $@ --start-group
+gnumach_o_LINK = $(LD) -u _start -r -o $@
noinst_PROGRAMS += \
gnumach.o