summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3fc7075..cb07e2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,6 +58,13 @@ AM_CFLAGS += \
AM_CFLAGS += \
-fno-strict-aliasing
+# The smashing stack protector might be enabled by default, but might emit
+# unsuitable code.
+if disable_smashing_stack_protector
+AM_CFLAGS += \
+ -fno-stack-protector
+endif
+
# For pre Automake 1.10.
AM_CCASFLAGS += \
$(AM_CPPFLAGS)