summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 76a192b..1c1bfff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,6 +63,11 @@ AM_CFLAGS += \
AM_CFLAGS += \
-fgnu89-inline
+# Much of the Mach code predates C99 and makes invalid assumptions about
+# type punning.
+AM_CFLAGS += \
+ -fno-strict-aliasing
+
# The smashing stack protector might be enabled by default, but might emit
# unsuitable code.
if disable_smashing_stack_protector