summaryrefslogtreecommitdiff
path: root/linux/configure.in
diff options
context:
space:
mode:
authorMarcus Brinkmann <marcus@gnu.org>2005-07-12 23:01:06 +0000
committerThomas Schwinge <tschwinge@gnu.org>2009-06-18 00:15:27 +0200
commit80fee10735b608b95cbcd01b97e3bd2e35d42c2d (patch)
tree9268c4ae4d42a4acc6a8b964331737bd513cc8ad /linux/configure.in
parent62bf63d99312f4d8ea2c148521dcff6c346741ad (diff)
2005-07-12 Guillem Jover <guillem@hadrons.org>
* configure: Regenerated. * i386/configure: Regenerated. * Drivers.macros (AC_DRIVER_CLASS): Use AH_TEMPLATE. (AC_DRIVER): Set the value for the AC_DEFINE and AC_DEFINE_UNQUOTED to 1. * aclocal.m4 (AC_PROG_CC_LOCAL, AC_PROG_CC_WORKS_LOCAL): Removed. * version.m4: New file. * Makefile.in: Use PACKAGE_VERSION, not VERSION. * doc/Makefile.in: Likewise. * version.c.in: Likewise. Use PACKAGE_NAME, not "GNUmach". * i386/linux/Makefile.in (configure): Change its source to configure.ac. * aclocal.m4: Add missing quotations. * Drivers.macros: Likewise. * configure.in: Likewise. Include version.m4 and use PACKAGE and VERSION m4 macros from it. * i386/configure.in: Likewise. (AC_INIT): Use new syntax and move source check to AC_CONFIG_SRCDIR. * i386/linux/configure.ac: Likewise. Use m4_sinclude, not sinclude. * linux/configure.in: Likewise. * i386/configure.in: Update AC_DEFINE to the new three argument form. * i386/linux/configure.ac: Move AC_DEFINE inside AC_ARG_ENABLE. * configure.in: Use AC_CONFIG_LINKS, not AC_LINK_FILES. * linux/configure.in: Likewise. * i386/configure.in: Call AC_CONFIG_FILES and use the new form of AC_OUTPUT. * i386/linux/configure.ac: Likewise. * linux/configure.in: Likewise * configure.in: Use AS_HELP_STRING in AC_ARG_ENABLE help strings. * Drivers.macros: Likewise. * i386/configure.in: Likewise. * i386/linux/configure.ac: Likewise. 2005-07-12 Neal H. Walfield <neal@cs.uml.edu> * configure.in: Update to use autoconf 2.57. Do not error out if host_os is not GNU. Update AC_DEFINEs to the required three argument form. Don't call AC_CHECK_TOOL(CC, gcc) and AC_PROG_CC_LOCAL, just use AC_PROG_CC. AC_SUBST(LDFLAGS). Refactor AC_CONFIG_SUBDIRS to not do variable substitution. Call AC_CONFIG_FILES and use the new form of AC_OUTPUT. * i386/configure.in: Require autoconf 2.57. * linux/configure.in: Likewise. * i386/linux/Drivers.in: Move from here... * i386/linux/configure.ac: ... to here to conform to the environment autoreconf expects. (hurd_host_CPU): New macro. Call AC_PROG_CC, not AC_PROG_CC_LOCAL. AC_SUBST(LD_FLAGS). (flashpoint): Update AC_DEFINE to the new three argument form. * Drivers.macros (AC_DRIVER): Update AC_DEFINE to the new three argument form.
Diffstat (limited to 'linux/configure.in')
-rw-r--r--linux/configure.in23
1 files changed, 15 insertions, 8 deletions
diff --git a/linux/configure.in b/linux/configure.in
index faf82bd..febc7df 100644
--- a/linux/configure.in
+++ b/linux/configure.in
@@ -1,5 +1,5 @@
dnl Configure script for linux code snarfed into GNU Mach.
-dnl Copyright 1999 Free Software Foundation, Inc.
+dnl Copyright 1999, 2004 Free Software Foundation, Inc.
dnl Permission to use, copy, modify and distribute this software and its
dnl documentation is hereby granted, provided that both the copyright
@@ -12,16 +12,23 @@ dnl "AS IS" CONDITION. THE FREE SOFTWARE FOUNDATION DISCLAIMS ANY
dnl LIABILITY OF ANY KIND FOR ANY DAMAGES WHATSOEVER RESULTING FROM THE
dnl USE OF THIS SOFTWARE.
-AC_INIT(src/include/linux/version.h)
-AC_PREREQ(2.12)
-sinclude([../aclocal.m4])
+m4_include([../version.m4])
+
+AC_INIT([PACKAGE],[VERSION])
+AC_CONFIG_SRCDIR([src/include/linux/version.h])
+AC_PREREQ(2.57)
+
+m4_sinclude([../aclocal.m4])
hurd_SYSTYPE
-AC_LINK_FILES(src/include/asm-${systype} dev/include/asm-${systype},
- src/include/asm dev/include/asm)
+AC_CONFIG_LINKS([src/include/asm:src/include/asm-${systype}
+ dev/include/asm:dev/include/asm-${systype}])
dnl We need to write these bogus output files to make autoconf create
dnl the directories where the directory symlinks need to go.
-AC_OUTPUT(src/.dummy:dummy.in dev/.dummy:dummy.in
- src/include/.dummy:dummy.in dev/include/.dummy:dummy.in)
+AC_CONFIG_FILES([src/.dummy:dummy.in
+ dev/.dummy:dummy.in
+ src/include/.dummy:dummy.in
+ dev/include/.dummy:dummy.in])
+AC_OUTPUT