summaryrefslogtreecommitdiff
path: root/i386/configure.in
diff options
context:
space:
mode:
authorMarcus Brinkmann <marcus@gnu.org>2005-07-12 23:01:06 +0000
committerThomas Schwinge <tschwinge@gnu.org>2009-06-18 00:15:27 +0200
commit80fee10735b608b95cbcd01b97e3bd2e35d42c2d (patch)
tree9268c4ae4d42a4acc6a8b964331737bd513cc8ad /i386/configure.in
parent62bf63d99312f4d8ea2c148521dcff6c346741ad (diff)
2005-07-12 Guillem Jover <guillem@hadrons.org>
* configure: Regenerated. * i386/configure: Regenerated. * Drivers.macros (AC_DRIVER_CLASS): Use AH_TEMPLATE. (AC_DRIVER): Set the value for the AC_DEFINE and AC_DEFINE_UNQUOTED to 1. * aclocal.m4 (AC_PROG_CC_LOCAL, AC_PROG_CC_WORKS_LOCAL): Removed. * version.m4: New file. * Makefile.in: Use PACKAGE_VERSION, not VERSION. * doc/Makefile.in: Likewise. * version.c.in: Likewise. Use PACKAGE_NAME, not "GNUmach". * i386/linux/Makefile.in (configure): Change its source to configure.ac. * aclocal.m4: Add missing quotations. * Drivers.macros: Likewise. * configure.in: Likewise. Include version.m4 and use PACKAGE and VERSION m4 macros from it. * i386/configure.in: Likewise. (AC_INIT): Use new syntax and move source check to AC_CONFIG_SRCDIR. * i386/linux/configure.ac: Likewise. Use m4_sinclude, not sinclude. * linux/configure.in: Likewise. * i386/configure.in: Update AC_DEFINE to the new three argument form. * i386/linux/configure.ac: Move AC_DEFINE inside AC_ARG_ENABLE. * configure.in: Use AC_CONFIG_LINKS, not AC_LINK_FILES. * linux/configure.in: Likewise. * i386/configure.in: Call AC_CONFIG_FILES and use the new form of AC_OUTPUT. * i386/linux/configure.ac: Likewise. * linux/configure.in: Likewise * configure.in: Use AS_HELP_STRING in AC_ARG_ENABLE help strings. * Drivers.macros: Likewise. * i386/configure.in: Likewise. * i386/linux/configure.ac: Likewise. 2005-07-12 Neal H. Walfield <neal@cs.uml.edu> * configure.in: Update to use autoconf 2.57. Do not error out if host_os is not GNU. Update AC_DEFINEs to the required three argument form. Don't call AC_CHECK_TOOL(CC, gcc) and AC_PROG_CC_LOCAL, just use AC_PROG_CC. AC_SUBST(LDFLAGS). Refactor AC_CONFIG_SUBDIRS to not do variable substitution. Call AC_CONFIG_FILES and use the new form of AC_OUTPUT. * i386/configure.in: Require autoconf 2.57. * linux/configure.in: Likewise. * i386/linux/Drivers.in: Move from here... * i386/linux/configure.ac: ... to here to conform to the environment autoreconf expects. (hurd_host_CPU): New macro. Call AC_PROG_CC, not AC_PROG_CC_LOCAL. AC_SUBST(LD_FLAGS). (flashpoint): Update AC_DEFINE to the new three argument form. * Drivers.macros (AC_DRIVER): Update AC_DEFINE to the new three argument form.
Diffstat (limited to 'i386/configure.in')
-rw-r--r--i386/configure.in24
1 files changed, 14 insertions, 10 deletions
diff --git a/i386/configure.in b/i386/configure.in
index 39aecf2..ddd7916 100644
--- a/i386/configure.in
+++ b/i386/configure.in
@@ -1,5 +1,5 @@
dnl Configure script for i386
-dnl Copyright 1999 Free Software Foundation, Inc.
+dnl Copyright 1999, 2004 Free Software Foundation, Inc.
dnl Permission to use, copy, modify and distribute this software and its
dnl documentation is hereby granted, provided that both the copyright
@@ -13,22 +13,26 @@ dnl LIABILITY OF ANY KIND FOR ANY DAMAGES WHATSOEVER RESULTING FROM THE
dnl USE OF THIS SOFTWARE.
-AC_INIT(i386/i386asm.sym)
-AC_PREREQ(2.12)
+m4_include([../version.m4])
+
+AC_INIT([PACKAGE], [VERSION])
+AC_CONFIG_SRCDIR([i386/i386asm.sym])
+AC_PREREQ(2.57)
#
# Options
#
-AC_ARG_ENABLE(lpr,
-[ --enable-lpr enable use of lpr device],
-[test "x$enableval" = xno || AC_DEFINE(MACH_LPR)])
+AC_ARG_ENABLE([lpr],
+AS_HELP_STRING([--enable-lpr], [enable use of lpr device]),
+[test "x$enableval" = xno || AC_DEFINE([MACH_LPR], [], [enable mach lpr])])
#
# Programs
#
-AC_CHECK_TOOL(LD, ld)
-AC_CHECK_TOOL(MAKE, make)
+AC_CHECK_TOOL([LD], [ld])
+AC_CHECK_TOOL([MAKE], [make])
-AC_CONFIG_SUBDIRS(linux)
+AC_CONFIG_SUBDIRS([linux])
-AC_OUTPUT(Makefile)
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT