summaryrefslogtreecommitdiff
path: root/i386/configure.in
diff options
context:
space:
mode:
authorThomas Schwinge <tschwinge@gnu.org>2006-09-19 23:12:49 +0000
committerThomas Schwinge <tschwinge@gnu.org>2009-06-18 00:26:41 +0200
commit65be2f5e021eb7a193be0b1314a1482e50743ba2 (patch)
tree719f18259080affd71636c0ad74b9fc1f2b67462 /i386/configure.in
parent9d9f61b8b9ad2c01182f11b470c20edf30702a4f (diff)
2006-09-20 Thomas Schwinge <tschwinge@gnu.org>
* Drivers.macros (AC_DRIVER_ALIAS): Remove definition. (AC_DRIVER): Extend to take a `description' parameter and consider `$enable_default_device_drivers'. (AC_DRIVER_nodef): New definition. * configure.in (options kdb, kmsg): Remove redundancy. * i386/configure.in (option default-device-drivers): New option. (option lpr): Consider `$enable_default_device_drivers'. * i386/linux/configure.ac: Rework substantially. Remove all aliases. Rename some of the device driver options. (option default-device-drivers): New option. (linux_DRIVER): Take care about a `description' parameter and don't invoke AC_DRIVER_ALIAS. (linux_DRIVER_nodef): New definition. Adopt all usages of AC_DRIVER and linux_DRIVER to provide a `description' parameter. (g_NCR5380, NCR53c406a, eata_dma, wavelan, atp): Change from AC_DRIVER to AC_DRIVER_nodef to have these device drivers disabled by default. * doc/mach.texi: Add a note about the outdatedness to the configuration option table. * i386/README-Drivers: Update.
Diffstat (limited to 'i386/configure.in')
-rw-r--r--i386/configure.in16
1 files changed, 14 insertions, 2 deletions
diff --git a/i386/configure.in b/i386/configure.in
index afc931b..93d7476 100644
--- a/i386/configure.in
+++ b/i386/configure.in
@@ -22,9 +22,21 @@ AC_PREREQ(2.57)
#
# Options
#
+AC_ARG_ENABLE([default-device-drivers],
+AS_HELP_STRING([--disable-default-device-drivers], [have all device drivers
+disabled that can be disabled and would otherwise have been enabled by default;
+then use the `--enable-*' options to enable only those you actually want to
+have enabled]))
+[if test x"$enable_default_device_drivers" != xno
+then enable_default_device_drivers=yes
+fi]
+
AC_ARG_ENABLE([lpr],
-AS_HELP_STRING([--enable-lpr], [enable use of lpr device]),
-[test "x$enableval" = xno || AC_DEFINE([MACH_LPR], [], [enable mach lpr])])
+ AS_HELP_STRING([--disable-lpr], [disable use of lpr device]))
+[enable_lpr=${enable_lpr-$enable_default_device_drivers}
+if test x"$enable_lpr" = xyes
+then] AC_DEFINE([MACH_LPR], [], [enable mach lpr])
+[fi]
AC_CONFIG_SUBDIRS([linux])