OpenID login issue: make sure that liblwpx-paranoidagent-perl is not installed.
[hurd-web.git] / public_hurd_boxen / installation / darnassus.mdwn
index 4fc9bfe..907be19 100644 (file)
@@ -17,7 +17,7 @@ License|/fdl]]."]]"""]]
 
   * ikiwiki libcgi-session-perl libtext-csv-perl libcgi-formbuilder-perl
     libauthen-passphrase-perl libnet-openid-consumer-perl
-    liblwpx-paranoidagent-perl libterm-readline-gnu-perl libgravatar-url-perl
+    libterm-readline-gnu-perl libgravatar-url-perl
     librpc-xml-perl libtext-wikiformat-perl libhighlight-perl perlmagick
     graphviz texinfo
 
@@ -29,6 +29,12 @@ License|/fdl]]."]]"""]]
 
       * libtext-markdown-perl (used instead of libtext-markdown-discount-perl)
 
+    Make sure that liblwpx-paranoidagent-perl is not installed; OpenID logins
+    with fail otherwise: *no_identity_server: Could not determine ID provider
+    from URL*.  Issue discovered on 2014-02-28, but unclear since when it did
+    actually occur.  Nothing in the apache logs.  Not fixed by the update to
+    ikiwiki 3.20140227.
+
   * gitweb highlight
 
         sudo ln -s ~hurd-web/hurd-web.git /var/lib/git/
@@ -241,39 +247,3 @@ The goal is that robots rather index the official pages,
     <tschwinge> braunr: gitweb installed, hurd-web URLs fixed
       (s%bddebian%darnassus), also some more ikiwiki-related Perl pacakges
       installed (openID login, for example).
-
-
-## IRC, freenode, #hurd, 2014-02-28
-
-    <gg0> braunr: "no_identity_server: Could not determine ID provider from
-      URL." trying to login to wiki with google account
-    <braunr> ?
-    <braunr> gg0: for the first question: how do you get that error ?
-    <gg0> "trying to login to wiki with google account"
-    <braunr> why tell me ?
-    <gg0> darnassus wiki
-    <braunr> tschwinge is the wiki administrator
-    <gg0> on darnassus too? oh didn't know
-    <tschwinge> gg0: [...], try to log in again
-      using OpenID.
-    <gg0> google button keeps saying "no_identity_server: Could not determine
-      ID provider from URL."
-    <cluck> gg0: i don't know what you're doing exactly but you might want to
-      double check your dns is working as expected (some anecdotal evidence
-      implies some dns servers around the word might be having issues)
-    <braunr> since the dns servers is on the sceen.net host machine which i
-      administer, and i have been very careful about its configuration, it
-      seems unlikely
-    <braunr> server*
-    <braunr> i don't see anything special in the logs
-    <braunr> something at the client side might be involved though
-    <cluck> braunr: as i said, i don't know what he's doing
-    <cluck> braunr: fwiw the cases that caught my attention are apparently
-      isp's dns servers
-
-
-### IRC, freenode, #hurd, 2014-03-01
-
-    <tschwinge> braunr, gg0: OpenID logins should again be working (no idea
-      when exactly it broke).  I needed to uninstall the
-      liblwpx-paranoidagent-perl package.