faq/libpthread_plugin -> faq/libpthread_dlopen.
[hurd-web.git] / faq / libpthread_plugin.mdwn
diff --git a/faq/libpthread_plugin.mdwn b/faq/libpthread_plugin.mdwn
deleted file mode 100644 (file)
index bcbe957..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-[[!meta copyright="Copyright © 2013 Free Software Foundation, Inc."]]
-
-[[!meta license="""[[!toggle id="license" text="GFDL 1.2+"]][[!toggleable
-id="license" text="Permission is granted to copy, distribute and/or modify this
-document under the terms of the GNU Free Documentation License, Version 1.2 or
-any later version published by the Free Software Foundation; with no Invariant
-Sections, no Front-Cover Texts, and no Back-Cover Texts.  A copy of the license
-is included in the section entitled [[GNU Free Documentation
-License|/fdl]]."]]"""]]
-
-[[!tag faq/open_issues]]
-
-[[!meta title="Getting Assertion `__pthread_threads' failed."]]
-
-Some applications don't link against libpthread, but load plugins which do link against libpthread. This means unexpectedly switch from mono-thread to multi-thread. This is not supported yet, thus the following error:
-
-    ./pthread/../sysdeps/generic/pt-mutex-timedlock.c:70: __pthread_mutex_timedlock_internal: Assertion `__pthread_threads' failed.
-
-This can be worked around by using
-
-export LD_PRELOAD=/lib/i386-gnu/libpthread.so.0.3